Ubuntu 10.04 ... ne peut pas plier !

Par , le dans Projet Folding@Home - 12 Commentaires
Ubuntu 10.04 ... ne peut pas plier !
De la même façon que Fedora dans ses dernières versions, Ubuntu 10.04 est victime du même "bug" ...

Un bug ? Pas vraiment ! En fait c'est la version de la libc6 (2.11.1 pour Ubuntu 10.04) qui est trop "moderne" pour la version avec laquelle a été compilé le client Linux. Une fonction interne dépréciée de la libc6 a été désactivée, et l'exécutable de Folding@Home affiche un message d'erreur fatal : "fah6: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in libc.so.6 with link time reference" :


Il semblerait que le client FAH6 Linux ait donc été compilé avec une version assez ancienne (2.2.5) et qui cette fois ci n'est plus compatible.

Nous avons prévenu Stanford que Ubuntu était à son tour touchée par ce problème. Nous attendons avec impatience une réponse pour savoir si une solution peut être trouvée vite. Quoi qu'il arrive, cette erreur est gênante mais pas incontournable ;)

EDIT du 25/04/2010 à 11h30 :
Voici un contournement pour corriger ce problème.
Merci à vb73.